Skip to main content
User avatar

Webserver timeout, not responding, but board responds to ping

Had something odd happen yesterday. My CNC was powered off for a few weeks and despite it behaving correctly before shutdown, when I powered it on and tried to connect the control page timed out. Connecting over USB was successful but gave me no further information about the issue.

I checked with the person who manages our network (ethernet) and they confirmed that when connected to a known good ethernet cable and port the board was responding to ping commands. But when scanned it showed a weird response on the web-server port, in their words the scanning software reported the web server as active but it wasn’t sure about it.

Then I took a stupid step. Lacking non-network methods for updating firmware I went to the Duet site and followed their instructions for installing firmware over USB. This involved formatting the SD card, and idiotically I did not make a backup. After the wipe, copying their card image, and configuring the correct IP address over USB, I was still not able to connect over the network.

At this point, I’m requesting a known good SD card image to burn and verify that this is not a software issue before I move on to exploring hardware related failures.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

User avatar

Hi Mateus,

Thanks for your email, if you email sales@ooznest.co.uk we can sort out some SD Card contents for you.

Robert

Was this answer helpful?

Score 0
Add a comment

Add your answer

Author avatar Mateus will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 41